Audi A6/S6 4F MSG an WFS anlernen


  • Audi A6, Typ 4F (04-11)
    6-Zyl. 2,7/3,0l Dieselmotor TDI
    163-232 PS Reparaturanleitung

    Hallo liebe Community!


    Da ich leider auch nach langer und intensiver Recherche nicht mehr weiterweiß suche ich auf diesem Wege Rat, vlt kann mir jemand helfen. Ich habe in meiner Garage einen Audi S6 4F 5.2 V10 von 10/2006 stehen. Ich habe das Fahrzeug mit einigen Schäden übernommen und baue das Fahrzeug nun wieder auf. Das klappt soweit ganz gut, nun bin ich soweit endlich den Motor starten zu wollen. Der Motor startet ganz kurz und geht dann sofort wieder aus, im Tageskilometerzähler steht dann "SAFE". Also habe ich einmal VCDS drangehangen und siehe da:


    Zugang- und Startberechtigung (0x05)

    02241 Motorsteuergerät, Wegfahrsperrendaten nicht angepasst

    02226 Motorsteuergerät 2, Wegfahrsperrendaten nicht angepasst

    Im Motorsteuergerät ist ebenfalls der Hinweis zu finden, dass der Wegfahrsperrencode nicht passt...


    Also habe ich mir jeweils die Messwertblöcke 081 im Stg01 (Motorsteuergerät) und Stg05 (Zugang- und Startberechtigung) angeschaut.

    Im Stg05 findet sich dort korrekt eingetragen die Fahrgestellnummer und die Wegfahrsperren ID.

    Im Stg01 sollten die gleichen Informationen zu finden sein, dies trifft auf die Fahrgestellnummer zu, die ist dort korrekt zu finden. Die Wegfahrsperren ID wird dort jedoch nicht angezeigt.


    Ich gehe davon aus, dass durch Unterspannung und viel rumgerödel die Kopplung der beiden verloren gegangen ist.


    Nach meiner Recherche sollte sich das Motorsteuergerät wieder an die Wegfahrsperre anlernen lassen durch die Funktion 10 Anpassung mit dem Kanal 050. Für die Ausführung dieser Funktion benötige ich allerdings einen Code für die Zugriffsberechtigung und vermutlich auch noch einen Code für die Wegfahrsperre...


    An dieser Stelle bin ich nun also ratlos, da ich diese Codes nicht habe und auch nicht weiss wo ich diese herbekommen soll. Gibt es jemanden der mir bei diesem Problem helfen kann?

  • Und im zweiten Motorsteuergerät? Was ist dort hinterlegt?


    Das einfachste wäre: zu Audi abschleppen, Online-Verbindung dran, und dann einmal alles auf Original.

  • Am einfachsten ist sicher: 1x zu Audi, WFS neu anlernen.


    Alternativ: einen "km-Anpasser bzw Codierer" zum Auto holen.


    Von wo bist du denn, dann könnte ich evtl jemand empfehlen...

  • Geld verdienen mit likes
  • Hallo,


    hast du KeyLess Go? Startest du über den Startknopf?


    Wenn ja starte den Wagen mal über das Zündschloss. War bei mir das gleiche Problem nachdem ich den Wagen lange offen stehen hatte.


    Gruß Timo

  • Danke für eure Beiträge! Motorsteuergerät 2 zeigt das gleiche an wie Motorsteuergerät 1: "P0513 Falscher Wegfahrsperrencode". Das Fahrzeug verfügt über Keyless Go, habe bereits versucht das Fahrzeug über Zündschloss einzuschalten. Der Fehler lässt sich auch löschen, kommt aber wieder sobald das Fahrzeug gestartet wird oder die Zündung neu eingeschaltet wird, je nachdem was zuerst eintritt.


    Da wird wohl langfristig nichts anderes übrig bleiben als das ich das Fahrzeug dann einmal abschleppen muss. Wäre schön gewesen eine Lösung zu finden, wo ich das nicht machen muss, da recht aufwändig. Hatte Anfragen zu diversen Firmen geschickt die laut deren Internetseiten Motorsteuergeräte modifizieren / WFS abschalten. Der finanzielle Aufwand wäre dann ähnlich hoch wie beim Abschleppen zu Audi...